RexNetworks - Minden Fibre - Power Loss – Incident details
All systems operational
Minden Fibre - Power Loss
Resolved
Partial outage
Started over 3 years agoFebruary 13, 2023Lasted about 2 hoursFebruary 13, 20239:1011:17 AMUTC
Updates
Resolved
UTC
Resolved
UTC
PowerCo have re-established power.
Investigating
UTC
Investigating
UTC
Our cabinet has lost mains power this evening and services are running on backup battery until PowerCo can restore.
Awaiting further updates from the lines company.