RexNetworks - Minden Hill Lane - Outage – Incident details

All systems operational

Minden Hill Lane - Outage

Resolved
Partial outage
Started 7 months agoLasted about 12 hours
Updates
  • Resolved
    Resolved

    PowerCo restore. Fibre cabinet restore.

  • Investigating
    Investigating

    Services are affected due to localised power outage. No current ETR. Awaiting PowerCo restore. Next update on status change.